[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Problem to generate plugins in format p2



2012/5/10 Hammed Mohamed <hammed.mohamed@xxxxxxxxx>

Hi all,

 

I have a problem to generate some plugins in format p2.

Let me explain you my use case :

-              I’m using a PDE headless build with ant commands to generate archives in p2 format.

-              The build process system is based on these files :

•             export.sh : this file export from SVN all features and plugins to be built (22 features and 42 plugins)

•             Build.sh : this file is used to launch the build with this command :

$JAVA_EXE -jar $STW_SDK/plugins/org.eclipse.equinox.launcher_1.1.3.0.jar -application org.eclipse.ant.core.antRunner -buildfile $BASE_DIR/build.xml build -vmargs -Declipse.exitdata=""

•             Build.xml : This file build all features

•             allElements.xml : for p2 I added to the target name group.group.group

•             build. Properties : contain all build properties and specially 2 parameters for p2 (p2.gathering = true and p2.compress=true)

•             features.xml :this file contain the features to be build.

-              The build finish with no failures and I found 18  p2 archives generated correctly (each zip file contain 2 folders :plugins, features and 2 files content.xml,artifact.xml) but for 4 others archives, the zip generated is missing the “features” folder !!

- I tried hard to identify the cause of this misbehavior but with no results L

 

Can someone help me please ?

 

Best regards,

Mohamed.