[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] p2 director not installing dependencies

Hi,

 

I’ve started using p2 director to provision an existing version of Eclipse, and I am trying to install the Subclipse plugin using it. I ran the install command:

 

eclipsec.exe -application org.eclipse.equinox.p2.director -repository http://subclipse.tigris.org/update_1.8.x/ -installIU org.tigris.subversion.subclipse.feature.group -tag InstallSubclipse -destination C:/eclipse-build-test/eclipse -profile epp.package.jee

 

The plugin was installed, but it seems like not all of its dependencies were installed. The subclipse feature.xml file has the following snippet

 

   <requires>

   …

      <import plugin="org.tigris.subversion.clientadapter" version="1.8.0" match="equivalent"/>

  …

  </requires>

 

But the client adapter does not get installed. Do I need to install that separately? Shouldn’t it be included since its required by the plugin I was installing?

 

Thanks,

Jeff