[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Bundle not unpacked after update

Are you able to reproduce this problem with a small example, or is this something that only happens in your environment? 

I took a quick look through the code, at it appears that the 'zipped' instruction should translate into 'aritfact.folder', meaning the artifact will be unzipped into a folder.  

Does this only happen on updates, or can you reproduce it with an initial install? Also, what version of p2 are you using when the install operation is happening?

Cheers,
Ian

On Wed, Jan 4, 2012 at 11:02 AM, Natalia Bartol <natalia.bartol@xxxxxxxxx> wrote:
Hello,

I have a feature that contains plugin which is marked to be unpacked after installation. However after updating this feature to a newer version this plugin remains as a jar. Both generated profile and update site metadata look correct, plugin's unit definition contains
 
<instruction key='zipped'>
            true
 </instruction>

anyway, the new plugin is downloaded but not extracted. 

Just for test I removed instruction key='zipped' from update site metadata and it fixed the issue...
I'm confused. 

Any hints will be appreciated!

Regards,
Natalia




_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev




--
R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
http://eclipsesource.com | http://twitter.com/eclipsesource