[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Bundle start configuration

My guess is that this is because the CU requirements on the IU are not specific enough and this causes the fragment to not be attached. The code is in the director AttachmentHelper.
This is likely a friend of https://bugs.eclipse.org/bugs/show_bug.cgi?id=263087 which we've discussed before.

On 2011-12-08, at 10:41 AM, Todorova, Katya wrote:

Hi guys,
 
I’m trying to install in Eclipse a bundle  published with  touchpoint instructions for start level = 3 & start = true (I use p2.inf in bundle META-INF to describe these).
As a result I get a strange mix of the local configuration and default bundle tooling presented in Eclipse – start level is 4 and start flag is true in the final bundles.info.
 
I assumed that local configuration would be preferred over the default one but it seems it’s not the case. What would be the correct behavior according to you?
 
Thank you,
Katya
 
 
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev