[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Versioning of p2.publisher.eclipse

For bug 247099, the behaviour of org.eclipse.p2.publisher.eclipse was changed so that optional runtime dependencies result in an optional, non-greedy p2 dependency instead of an optional greedy dependency. This is an incompatible change. Should we therefore increment the version number to 2.0.0? Technically, this would not be necessary, because all of the bundle is marked as internal.
 
As a good compromise, I would suggest a minor increment to 1.1.0.qualifier. What do you think?
 
Regards
Tobias