[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Pending patches in preparation to Git move

The faulty projects will not be part of the git repo as requested http://dev.eclipse.org/mhonarc/lists/p2-dev/msg04231.html

On 2011-07-11, at 6:12 PM, Matthew Piggott wrote:

I added this to the bug, but it appears that the problem may be due to a project that isn't part of the p2 psf.   The project org.eclipse.equinox.p2.repository.impl has the name "org.eclipse.equinox.p2.repository" and attempts to import old packages which have been moved.  This also prevents the real org.eclipse.equinox.p2.repository from being imported, maybe double check to see if this was the problem you encountered.

Matthew

On 11/07/2011 9:25 AM, Todorova, Katya wrote:

I used this bug to continue investigation:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=345474

 

Thanks,

Katya

 

From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Thomas Watson
Sent: lundi 11 juillet 2011 14:59
To: P2 developer discussions
Subject: Re: [p2-dev] Pending patches in preparation to Git move

 

As of now I believe that repo is the test repo for the p2 migration. Although if you are seeing strangeness with it then it may indicate a problem encountered when they did the test migration to create the repo.

Tom



<Mail Attachment.gif>"Todorova, Katya" ---07/11/2011 06:36:41 AM---Guys,

<Mail Attachment.png>
From:

<Mail Attachment.png>
"Todorova, Katya" <katya.todorova@xxxxxxx>

<Mail Attachment.png>
To:

<Mail Attachment.png>
P2 developer discussions <p2-dev@xxxxxxxxxxx>

<Mail Attachment.png>
Date:

<Mail Attachment.png>
07/11/2011 06:36 AM

<Mail Attachment.png>
Subject:

<Mail Attachment.png>
Re: [p2-dev] Pending patches in preparation to Git move





Guys,

Is git.eclipse.org/gitroot/equinox/rt.equinox.p2.git supposed to be ready to use?

I tried cloning it and the operation seems to finish successfully but afterwards most of the projects (when imported in Eclipse) don’t compile properly.
For example p2.repository doesn’t see some of the exported packages by p2.core.

Any idea what’s wrong?

Thanks,
Katya


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev