[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Moving to 3.7 my Update is not working anymore

I don't give up :) Hope that someone will give me a hint anyway.

If I do a IMetaDataRepositoryManager.load I see GET/HEAD requestes on p2.index and content.jar.
But I do not see any request on my artifacts.jar. but it is configured in
p2\org.eclipse.equinox.p2.engine\.settings (see file)

Any hint will be greatly appreciated. I  want to show a working release on the DemoCamp :)

Regards Thomas


2011/6/15 Thomas Kratz <eiswind@xxxxxxxxxxxxxx>
Further investigations show that I can only find a nearly empty artifacts.xml in the p2 core cache
(I'll attach it). Seems that it doesn't pick up the remote file for any reason.(?)
The repo is correct and building the product with buckminster or by the p2 installer works fine.
Still seriously hoping for any hint :)

Regards Thomas

2011/6/14 Thomas Kratz <eiswind@xxxxxxxxxxxxxx>
Hi again,

does anyone have an idea about this? The artifact is definitively present in the repo. I am installing the product from the repo with a 3.6 based p2 installer which works fine. Only the updates aren't working which drives me crazy.

Any help will be appreciated.


2011/6/13 Thomas Kratz <eiswind@xxxxxxxxxxxxxx>
Hi Pascal,

I made a little progress by manually adding the repo like:
ProvisioningContext result = new ProvisioningContext(getAgent(context));
result.setArtifactRepositories(new URI[] { repoURIs[0] });
 result.setMetadataRepositories(new URI[] { repoURIs[0] });
 IMetadataRepositoryManager repoManager =
 (IMetadataRepositoryManager) agent.getService(IMetadataRepositoryManager.SERVICE_NAME);
repoManager.loadRepository(repoURIs[0], new
NullProgressMonitor());

with this setting  the qurey runs fine, my product IU is found, but running the Update I get tons of
!SUBENTRY 1 org.eclipse.equinox.p2.artifact.repository 4 0 2011-06-13 14:30:51.289
!MESSAGE No repository found containing: osgi.bundle,de.eiswind.mango.client.book,1.7.0.201106131429
Google says this was a problem with 3.6.1 and it should be fixed.
Do you have an idea about that?
I'll take a walk now, tired of running builds.

Regards Thomas

2011/6/12 Pascal Rapicault <pascal@xxxxxxxxxxxx>
Do you have ds started?
Do you have ecf.provider.filetransfer.httpclient?

I'm running short of ideas :)
Do you have a simple example that you can share with the ml?



On 2011-06-12, at 2:12 PM, Thomas Kratz wrote:

Hi Pascal,

today I've added the core feature with the missing bundle. But still I don't even see an incoming http request on my repository. Any more ideas?

Regards Thomas

2011/6/6 Pascal Rapicault <pascal@xxxxxxxxxxxx>
You are at least missing org.eclipse.equinox.p2.transport.ecf. This is a new bundle introduced in 3.7.
Rather than continuously building this list by hand, I strongly encourage you to include the org.eclipse.equinox.p2.core.feature.
However note that this feature only includes the bare minimum and will not bring in support for legacy update sites (pre eclipse 3.4) which I'm not sure you need.
I would also recommend the same approach for RCP.

HTH

P

On 2011-06-06, at 3:15 AM, Thomas Kratz wrote:

Hi again,
 I'll attach my complete dependencies, maybe I have made a mistake there.


2011/6/5 Pascal Rapicault <pascal@xxxxxxxxxxxx>
Could you please post the list of bundles that you have been using?
Also note that in 3.7, we have been facilitating the consumption of p2 by adding a feature called: org.eclipse.equinox.p2.core.feature

On 2011-06-05, at 2:32 PM, Thomas Kratz wrote:

> Hi with the help of you people I managed to get an update at startup that used to work fine on 3.6. But as I moved to 3.7 it's not even querying my repo anymore (no access in the apache logs at startup). Is there some Service I need to start or something else thats new ?
>
> I'll attach my code, it only updates to a certain version normally. Just getting crazy once again.
> Any hint will be greatly appreciated.
>
> Thomas
> <UpdateManager.java>_______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev

<feature.xml>_______________________________________________


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev





Attachment: org.eclipse.equinox.p2.artifact.repository.prefs
Description: Binary data