[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Moving to 3.7 my Update is not working anymore

You are at least missing org.eclipse.equinox.p2.transport.ecf. This is a new bundle introduced in 3.7.
Rather than continuously building this list by hand, I strongly encourage you to include the org.eclipse.equinox.p2.core.feature.
However note that this feature only includes the bare minimum and will not bring in support for legacy update sites (pre eclipse 3.4) which I'm not sure you need.
I would also recommend the same approach for RCP.

HTH

P

On 2011-06-06, at 3:15 AM, Thomas Kratz wrote:

Hi again,
 I'll attach my complete dependencies, maybe I have made a mistake there.


2011/6/5 Pascal Rapicault <pascal@xxxxxxxxxxxx>
Could you please post the list of bundles that you have been using?
Also note that in 3.7, we have been facilitating the consumption of p2 by adding a feature called: org.eclipse.equinox.p2.core.feature

On 2011-06-05, at 2:32 PM, Thomas Kratz wrote:

> Hi with the help of you people I managed to get an update at startup that used to work fine on 3.6. But as I moved to 3.7 it's not even querying my repo anymore (no access in the apache logs at startup). Is there some Service I need to start or something else thats new ?
>
> I'll attach my code, it only updates to a certain version normally. Just getting crazy once again.
> Any hint will be greatly appreciated.
>
> Thomas
> <UpdateManager.java>_______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev

<feature.xml>_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev