[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] p2 update - force specific arch update

I guess you have to launch java with the 32 bit parameter on 10.6. look at my jnlp files at www.buchmanager.com/installer/installer.jnlp

Thomas

2011/5/24 Mariusz Florek <mariusz.florek@xxxxxxxxxxxx>

I use eclipse 3.5.1. Product is generated from 64 bit version using following settings:

baseos=macosx

basews=cocoa

basearch=x86

 

From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Mariusz Florek
Sent: Tuesday, May 24, 2011 6:08 PM
To: p2-dev@xxxxxxxxxxx
Subject: [p2-dev] p2 update - force specific arch update

 

Hi,

 

My environment:

MAC OS X; 10.6.4; 32 bit

 

I exported an eclipse product.

I run it with following program args (because it uses 32 bit java and arch):

-arch

x86

 

When p2 update is performed launcher is downloaded from x86_64 architecture.

 

How to force p2 update to use x86 architecture?

 

I tried to add:

-p2.arch x86

to eclipse.ini files (with no changes)

 

Regards,

Mariusz

 


_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev