[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Can p2 director be used to update a installed feature?

Thank you, Sebastien.

Best Regards

Samuel Wu


Inactive hide details for "Angers, Sebastien" ---05/04/2011 12:12:12 PM---Bonjour Samuel,"Angers, Sebastien" ---05/04/2011 12:12:12 PM---Bonjour Samuel,


From:

"Angers, Sebastien" <Sebastien.Angers@xxxxxxxxxxxxx>

To:

"P2 developer discussions" <p2-dev@xxxxxxxxxxx>

Date:

05/04/2011 12:12 PM

Subject:

Re: [p2-dev] Can p2 director be used to update a installed feature?

Sent by:

p2-dev-bounces@xxxxxxxxxxx




Bonjour Samuel,

Interesting; we are trying to do the same thing.

You should look/follow Bug 279659; there’s a patch that has been contributed (thanks to Katya Todorova for the contribution!) which is providing an updateIU option to the director application. (I’ve not tested it yet)

The Bug also contains good discussions on this requirement.

Regards,

Sébastien




Le contenu de ce courriel s'adresse au destinataire seulement. Il contient de l'information pouvant être confidentielle. Vous ne devez ni le copier ni l'utiliser ni le divulguer à qui que ce soit à moins que vous soyez le destinataire ou une personne désignée autorisée. Si vous le receviez par erreur, veuillez nous aviser immédiatement et le détruire.

The contents of this e-mail are intended for the named addressee only. It contains information that may be confidential. Unless you are the named addressee or an authorized designee, you may not copy or use it, or disclose it to anyone else. If you received it in error please notify us immediately and then destroy it.

From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Samuel Wu
Sent:
Wednesday, May 04, 2011 11:59 AM
To:
p2-dev@xxxxxxxxxxx
Subject:
[p2-dev] Can p2 director be used to update a installed feature?

I have a feature com.abc.main.feaature 3.6.2.01 installed in Eclipse SDK 3.6.2. I'm trying to update it to 3.6.2.02 from the command line with the p2 director.

eclipse.exe -application org.eclipse.equinox.p2.director -repository file:/D:/temp/eclipse-SDK-3.6.2/eclipse/workspace/Update/ -installIU com.abc.main.feaature.feature.group

I got the error message in the configuration directory, saying that Cannot complete the install because of a conflicting dependency. Only one of the feature com.abc.main.feaature can be installed. Is there another application which can update the installed feature?

Best Regards

Samuel Wu
IBM Canada, Toronto Lab
samuelwu@xxxxxxxxxx
Tel: 905-413-2373
Fax: 905-413-4854

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev

GIF image

GIF image

JPEG image