[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Problems creating categories

Hello stellar p2 team -- 

Thanks for the great presentations at EclipseCon.

I am trying to create a local p2 site to provide our own controlled version of Eclipse for in-house developers.  As such I want to provide cross-platform support, some of our own plugins / features, and some 3rd party features which not all of our developers will want to use.  

I have created a category.xml file via the PDE UI that nicely categorizes these different features.  The problem I run into is that when I use either the command line or the PDE or Buckminster tools to create the p2 update site, the published site does not have the features I have specified in the categories I have created.

I have set (and fiddled around with) these properties in my build.properties file:
p2.gathering = true
#generate.p2.metadata = true
p2.flavor = tooling 
p2.publish.artifacts=true 
#p2.category.site = file://absolute/path/site.xml
p2.category.definition = file://absolute/path/category.xml
category.default=gov.nasa.ensemble.eclipse.ide

I suspect that the issue is that my RCP product does not require all the features in the categories; but those features are included by the feature I am using to define & create the categories.  To clarify:

my_category_feature_project
  feature.xml - includes my_product_feature, other goodies (ie git features, modeling features, etc)

my_product_feature
  feature.xml - includes my_product_plugin, eclipse_rcp, eclipse_help, subversion features and other basic required stuff

What SHOULD I be doing to get the results I want?

thanks much

Tamar Cohen