[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] p2ql Finding everything requiring a specific IU

Hi All, and Thomas in particular :)

We have support in the metadata to write a requirement in terms of the p2ql.  I'm trying to write something to match IUs that have a requirement on a specific version on another IU.

This is what I tried:
<required match='requirements.exists(rc | rc.namespace=='org.eclipse.equinox.p2.iu' &&
                                                      rc.name=='org.eclipse.equinox.launcher' &&
                                                      rc.range~=version('1.1.0.v20100507'))' />

This does not work because RequiredCapability does not provide those members.  It does have a "match" member which is the match _expression_ for the requirement.
At this point I have not been able to figure out how to complete the _expression_:
<required match='requirements.exists(rc | rc.match ~= ??? "
               matchParameters='???' />

Any help would be appreciated.

--Andrew