[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Keep an eye on mixed mode projects 1.4/1.5 projects

In Equinox/p2 we are using jsr14 to be able to compile 1.5 java code to run on J2SE 1.4 VM. For the most part this has been working well for us, but it has caused quite a few headaches for the JDT team because now they are having to deal with cases where 1.4 and 1.5 projects are mixed together and cause interesting issues for the compiler and reconciler. The JDT team is planning to release several fixes for 1.4/1.5 "mixed" mode for this weeks I-Build. For this weeks I-Build please keep an eye out for any strange errors you may see in your projects that use jsr14 or any projects that may depend on your projects that use jsr14. I recommend you perform a clean build of your workspaces to make sure they continue to build correctly once you upgrade to this weeks I-Build.

Below are a couple of examples of bugs that we uncovered last week:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=329584
https://bugs.eclipse.org/bugs/show_bug.cgi?id=329588

Tom