[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] How does p2 check for plugin/dependencies versions for download

Nayna - it is *likely* to be the second reason; that's all one can say,
unless one is sure about the dependencies between CDT and Mylyn (if at all
such a dependency exists).

Assuming dependencies have been defined clearly, if an update of one
component requires update of another, that is typically made clear to the
user.

Pradeep


                                                                       
  From:       Nayna Jain <jainnayna@xxxxxxxxx>                         
                                                                       
  To:         P2 developer discussions <p2-dev@xxxxxxxxxxx>            
                                                                       
  Date:       09/14/2010 06:27 PM                                      
                                                                       
  Subject:    Re: [p2-dev] How does p2 check for plugin/dependencies versions for	download
                                                                       
  Sent by:    p2-dev-bounces@xxxxxxxxxxx                               
                                                                       





Hi Daniel,
Thanks for the immediate response.

Actually I was confused that is it like CDT 6.0.2 need Mylyn 3.4.x , that's
why those are listed.. Or they are listed just because p2 contacted all the
update sites of all the dependencies of  the initial request and it didn't
find the latest version of Mylyn in the existing installation so listed
them.

So, I guess it is the second reason.. that is happening. Right ?

Also, if it would have been that CDT 6.0.2 needs Mylyn 3.4.x.. then I guess
it won't have shown in the list but would have installed them by itself..
Am I right ? And if it would have shown I guess it would have listed them
in any case whether check-box is selected or not.. Is my understanding
right ?

Thanks  & Regards,
       - Nayna Jain



On Tue, Sep 14, 2010 at 3:58 PM, Daniel Le Berre <
leberre@xxxxxxxxxxxxxxxxxxx> wrote:
  Hi Nayna,

  The basic idea is that p2 is updating if available all the dependencies
  of the initial request.

  So if you do not contact all the update sites, you are not going to see
  the update of mylyn, so p2 will not pick it.

  Checking "contact all the repositories" will allow p2 to see that
  update, so it will pick it.

  You can see the details of the new scheme introduced in Eclipse 3.6
  discussed here:
  https://bugs.eclipse.org/bugs/show_bug.cgi?id=259537

  Cheers,

         Daniel

  Le 14/09/2010 11:53, Nayna Jain a écrit :
  > Hi everybody,
  >
  > I have one basic doubt from the Install dialog page we get when we
  click
  > Help -> Install New Software in Eclipse.
  > On this dialog page there is one checkbox . " Contact all update sites
  > during install to find required software".
  >
  > So, what does the required software means here ? And what does it
  > actually try to check in update sites.
  >
  > Why I got this doubt is as below :-
  >
  > I had Eclipse IDE for Java base installation. With it Mylyn 3.2.x
  > versions got installed.
  > Now using Eclipse Install New Software link.. I am trying to install
  > C/C++ Development Toolkit.
  > The checkbox on "Contact all update sites during install to find
  > required software" is selected.
  >
  > Now, when I click on Next.. it calculates the dependencies and moves to
  > Next Dialog.. It shows CDT.. with size details and goes to next license
  > page..
  > Now it shows.. both CDT and Mylyn 3.4.x versions.. I know CDT has
  > dependency on Mylyn but does it need 3.4.x version only as 3.2.x
  version
  > is already available.. And if I don't select on this checkbox then it
  > doesn't show Mylyn 3.4.x plugins.
  >
  > So.. what does it actually try to do ?
  >
  > #1. Is CDT 6.0.2 having dependency on Mylyn 3.4.x thats why it is
  showing.
  > #2. Or is CDT 6.0.2 can work with Mylyn 3.2.x also but since we asked
  it
  > to contact all the update sites.. so when i went to Mylyn update site..
  > it found the latest version 3.4.x.. to be available and so started
  > downloading that also.
  > #3. Or is it like when we select this checkbox.. it looks for update
  > sites of all the plugins irrespective of the it is required for
  > currently selected plugin or not.
  >
  > So, please clarify it.. And if it is like #1. then how do I provide
  this
  > option when I am using p2 director applicaton headlessly using bash
  script.
  >
  > How do I specify in my bash script to contact all the update sites
  > during install for the required software.
  >
  > Thanks & Regards,
  >               - Nayna
  >
  > --
  > Don't believe the fear, uncertainity and doubts from people that have
  > never tried it.
  >
  >
  >
  > _______________________________________________
  > p2-dev mailing list
  > p2-dev@xxxxxxxxxxx
  > https://dev.eclipse.org/mailman/listinfo/p2-dev


  --
              Daniel Le Berre mailto:leberre@xxxxxxxxxxxxxxxxxxx
              MCF,    CRIL-CNRS UMR 8188,    Universite d'Artois
              http://www.cril.univ-artois.fr/~leberre
  _______________________________________________
  p2-dev mailing list
  p2-dev@xxxxxxxxxxx
  https://dev.eclipse.org/mailman/listinfo/p2-dev



--
Don't believe the fear, uncertainity and doubts from people that have never
tried it._______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev