[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Unable to add p2 repository via proxy

FWIW,

I'm not sure if this is what you are experiencing, but FYI there was some work on the proxy authentication in the most recent release cycle...see this comment (in particular the short summary of situation at bottom of comment)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=295030#c61

Also see this later comment (after the workaround was introduced)

https://bugs.eclipse.org/bugs/show_bug.cgi?id=295030#c82

Finally, these two bugs have been opened to track further needed work on the core.net proxy API coming out of this workaround:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=312224
https://bugs.eclipse.org/bugs/show_bug.cgi?id=312228

Again, I'm not certain that your proxy issues are due to the same cause, but it seems possible to me, as ECF filetransfer simply uses the core.net proxy API.

Scott


Dmytro Pishchukhin wrote:
Hi,

I know only proxy host and port and do not have any access to proxy server configuration. But maven and the other Java applications access outside URLs without any problems. I think, that the cause of error is somewhere inside ECF or even in lower level.

Best regards,
Dmytro Pishchukhin


On Mon, Jul 5, 2010 at 15:12, Leslie H. Watter <leslieh@xxxxxxxxxxxxxxxxx <mailto:leslieh@xxxxxxxxxxxxxxxxx>> wrote:


    Hi,

    Em Fri, Jun 25, 2010 at 03:12:43PM +0200, Dmytro Pishchukhin escreveu:
    | From: Dmytro Pishchukhin <dmytro.pishchukhin@xxxxxxxxx
    <mailto:dmytro.pishchukhin@xxxxxxxxx>>
    |
    |    I've tried to run console command to add p2 repository.
    |
    |    I've tried it via and without proxy. Direct access work fine,
    but I have
    |    an exception when I try to connect via proxy:
    |    osgi> provaddrepo http://download.eclipse.org/releases/helios
    |    java.lang.UnsupportedOperationException: Repository not
    modifiable:
    |    http://download.eclipse.org/releases/helios
    |    My eclipse.ini;
    |    -startup
    |    plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
    |    -console
    |    -Dhttp.proxyHost=<host>
    |    -Dhttp.proxyPort=<port>

    I've had problems here using eclipse with proxy when the proxy
    implements digest authentication.

    You could take a look at your proxy configuration. It worked fine
    to me
    when using basic authentication.

    Hope this help.

    Cheers,

    LEslie
    _______________________________________________
    p2-dev mailing list
    p2-dev@xxxxxxxxxxx <mailto:p2-dev@xxxxxxxxxxx>
    https://dev.eclipse.org/mailman/listinfo/p2-dev


------------------------------------------------------------------------

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev