[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] P2-Update-SDK: Dependency to org.eclipse.compare

Hi,

We just updated the development environment for our Eclipse-RCP-Application Horus to Eclipse 3.6. This causes us the following Problem: We're using the ep2-update mechanism by adding the commands org.eclipse.equinox.p2.ui.sdk.update and org.eclipse.equinox.p2.ui.sdk.install to one of our menus and adding a dependency to org.eclipse.equinox.p2.ui.sdk.

This was fine for eclipse 3.5. But with the new p2.ui.sdk in Helios, this bundle has a new dependency to org.eclipse.compare. This is quite bad for us, since org.eclipse.compare has another dependency to org.eclipse.ui.ide. This leads to quite a lot of bundles that wouldn't be needed otherwise in our application.

To solve the problem, I checked out the 3.6-p2.ui.sdk from cvs, removed the org.eclipse.compare dependency and its RevertProfilePageWithCompare class. After removing the org.eclipse.ui.installationPages extension from the p2.ui.sdk-plugin.xml everything is fine for me.

But I think this dependency is ugly for quite some other rcp-developers. Wouldn't it be possible to make this dependency optional? Or split this installation-page-things up into another bundle?


Best regards,
Johannes
Horus software GmbH
http://www.horus.biz