[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Help needed: P2 UpdateSitePublisher doesn't add instruction to unzip plugin, although feature.xml hasn't unpack="false" ?

Hi all,

I hope this is the right place for such questions, please redirect me
if I'm wrong.

We have a strange issue where we create an update-site. We assemble
org.junit4 in one of our features and build an update site out of
that. If we want to consume the generated update site from Eclipse as
target platform we get errors because the junit-plugin isn't unzipped
(and the nested junit.jar can not be resolved by the PDE design-time).

I found that the generated content.xml only contains the manifest data
as touchpointData/instruction, but no <instruction
key='zipped'>true</instruction>. If I add that zipped-instruction
manually to the content.xml the IDE correctly unzips the plugin.

We build using tycho, but I can also reproduce the problem if I invoke
the UpdateSitePublisher directly from the command line. Can anybody
explain what we're doing wrong here?

The junit-plugin is basically the same as in Eclipse itself, no
Eclipse-BundleShape in the MANIFEST-MF.

Our feature.xml contains:
 <plugin  id="org.junit4" install-size="201" version="0.0.0"
download-size="172"/>

I also tried with an explicit unpack="true", but that didn't make any
difference either.

What is required here to convince the UpdateSitePublisher to include
the key='zipped'- instruction?

Thanks and best regards,
Marc