[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Strange issues with update site = pulling my hair out

Which version of Eclipse are you using?

Le 10 mars 2010 à 16:45, Chris Gross a écrit :

> I’m hoping someone here can help me with some really weird behavior I’m seeing with p2.  I’m having multiple problems with what I believe is a very straight forward scenario.
>  
> I have 3 plugins, one feature, and one update site.  Installing the feature/plugins through the update site was easy and successful.  My problems are coming now that I try to release a new version and update those installations.
>  
> First problem:
> I’ve got my updated plugins (new code, bug fixes, etc).  I incremented the version number on those plugins (from 1.0.0 -> 1.0.0.001).  I updated the feature version number similarly.  Rebuilt the update site.  Redeploy update site.  The Eclipse installation notices I have a new version, downloads the new plugin (or seems to), but then when I use the plugin – the code seems to be the original code from the 1.0.0 version?!?  And if I look in the Product Details dialog I notice the plugin version is still 1.0.0..??
>  
> Second problem:
> In experimenting to fix this problem, I created a whole new Eclipse installation, installed the 1.0.0.001 version from the start.  Works fine.  Now I tried to uninstall 1.0.0.001 and installed 1.0.0 back in.  Now I’m having a similar problem as above.  This time the code still seems to be at 1.0.0.001 version even though I uninstalled that and installed 1.0.0.  Checking the Product Details dialog shows version 1.0.0 installed.  I even checked the /plugins directory and it shows a 1.0.0 plugin as well.  Yet the actual code that’s getting executed is definitely 1.0.0.001..?!
>  
> I’ve tried deleting some of the cache files in the p2 directory.  That didn’t seem to change anything. 
>  
> Please help.
>  
> -Chris
>  
> _______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev