[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] MatchQuery

On 03/10/2010 02:41 AM, Thomas M Houser wrote:

In my subclass, this call to the super constructor does not compile:

        super(IInstallableUnit.class, ExpressionUtil.TRUE_EXPRESSION);

Are clients of the p2 API now required to compile with javacSource=1.5 and javacTarget=1.5?  Or is there some trick here?

Yes, the last parameter is a varargs (and in this case there are none), so in order to compile with 1.4 you need:

 super(IInstallableUnit.class, ExpressionUtil.TRUE_EXPRESSION, new Object[0]);

- thomas