[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Problem/Question about Update...

Hi,

I'm trying to update to a newer p2 in my M5 updated, Helios M4 JEE install by pointing to an unzipped equinoxSDK build in "Install New Software". The updater recognizes that bundles are previously installed, and will update them instead. However, it says it cannot proceed because there are dependency conflicts.

As I add features to try and remove conflicts, I get others. Until I am requesting to install the entire Equinox SDK over JEE M5, at which point it appears that I cannot proceed because the JEE package depends upon a version of eclipse.equinox.preferences.mechanism which is trying to be replaced by equinox. I'm including a jpg of the dialog.

I am obviously doing something wrong, since I was asked to update p2 to a later build, but cannot do so. It appears I can only update the jee package without error, but jee does not yet contain the version of p2 that I need.

What am I missing? is there a specific p2 site (for p2, or the JEE package) I need?

Thanks.
--
-Eric

Oracle <http://www.oracle.com>
Eric Gwin | Senior Software Developer
Phone: +613 288 4622 <tel:+613%20288%204622> | | Fax: +613 2382818 <fax:+613%202382818> | | Mobile: +613 8582347 <tel:+613%208582347>
Oracle Java Server Technologies
ORACLE Canada | 45 O'Connor St., Ottawa, Ontario | K1P 6L2
Green Oracle <http://www.oracle.com/commitment> Oracle is committed to developing practices and products that help protect the environment


JPEG image