[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Problems with org.eclipse.equinox.p2 plugins

Hello ,

 I am having issues with the org.eclipse.equinox.p2 plugins....

I am running a headless build in RAD which is not p2 based. If I use the
old org.eclipse.equinox.p2 plugins I used to use, there is no problem, the
test runs I am trying will run/build.

If I use the updated plugins from the latest releases though the runs will
fail at runtime giving errors such as "cannot find NLS" or "Cannot find
org.eclipse.osgi" , and many many more where it cannot find org.eclipse.*
stuff.

Did anything change from the previous versions that could be affecting me?

As I said I am using a stripped down version of RAD and running headless
builds from command line. The plugins that cannot be found are all
physically there in the plugins/ folder. If I use the "newest" version
available of the org.eclipse.equinox.p2 plugins the errors will show... If
I replace these with the older versions then the errors wont show and the
run will be successfull.

I also find that the new version  of the org.eclipse.pde.core plugin is
causing the same problems. I am not sure if these may be related.

Thanks ahead for you feedback


Best Regards
Mattia Parigiani
RAD - Application Build
Tel. 01(33) 36697000 ext 5558
T.L. 8877-5558
parigian@xxxxxxxxxxx