[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] "ACLVB Applicatie" is already installed, so an update will be performed instead.

Hi all,

I followed this great tutorial
(http://www.ralfebert.de/blog/eclipsercp/p2_updates_tutorial/) to update
your application using the p2 provisioning system. And I was able to
completely finish the tutorial and my demo application was updated (both
through the p2 ui as an auto-update at startup of my application).

Now I try the same procedure at our own application:
- I have a feature containing all our custom plugins
- I have a product containing 3 features: our own feature, org.eclipse.rcp
and org.eclipse.equinox.p2.user.ui

I export our application and I have an application and a repository. When I
make a (visible) change to our application, I export the application again
(using the export product wizard) and I publish the new repository to our
update site.
When I click on "Check for Updates" I get a message telling me there is
nothing to update.
When I click on "Install new Software" the new version of our application
is listed and when I select it and click on next I get the following error
message (and I'm not able to complete the wizard and can't update my
application).

Your original request has been modified.
  "ACLVB Applicatie" is already installed, so an update will be performed
instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: ACLVB Applicatie 1.0.0.201002221740
(be.aclvb.applicatie.feature.group 1.0.0.201002221740)
  Software currently installed: be.aclvb.client.application.product 0.0.0
  Only one of the following can be installed at once:
    be.aclvb.applicatie_root 1.0.0.201002221740
    be.aclvb.applicatie_root 1.0.0.201002221727
  Cannot satisfy dependency:
    From: ACLVB Applicatie 1.0.0.201002221727
(be.aclvb.applicatie.feature.group 1.0.0.201002221727)
    To: be.aclvb.applicatie_root [1.0.0.201002221727]
  Cannot satisfy dependency:
    From: ACLVB Applicatie 1.0.0.201002221740
(be.aclvb.applicatie.feature.group 1.0.0.201002221740)
    To: be.aclvb.applicatie_root [1.0.0.201002221740]
  Cannot satisfy dependency:
    From: be.aclvb.client.application.product 0.0.0
    To: be.aclvb.applicatie.feature.group [1.0.0.201002221727]

I'm using Eclipse 3.5 (Build id: 20090920-1017) and it is not an option to
upgrade Eclipse to another version.

I'm wondering why the updating process is failing and what mistakes I'm
making. I appreciate any hints, tips and comments to solve this problem.

Thanks a lot for your time!

Kind regards,
Roel
**********************************************************************
"This e-mail and any attachments thereto may contain information 
which is confidential and/or protected by intellectual property 
rights and are intended for the sole use of the recipient(s) named above. 
Any use of the information contained herein (including, but not limited to, 
total or partial reproduction, communication or distribution in any form) 
by persons other than the designated recipient(s) is prohibited. 
If you have received this e-mail in error, please notify the sender either 
by telephone or by e-mail and delete the material from any computer. 
Thank you for your cooperation."
**********************************************************************