[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Asking for advice from p2-experts

Am 02.02.10 22:15, schrieb Pascal Rapicault:
> I was just trying to install the core pieces which is why I did not see
> the error.
> I can now get the same error and the message indicates that you are
> looking for a core feature whose version should be [1.0.0.qualifier,
> 2.0.0). The problem is that is smaller than 1.0.0.qualifier
> and as such the dependency can't be satisfied. So the resolver and the
> error messages are correct.
> Now what is suspicious is that your metadata still contains ".qualifier"
> whereas this should have been replaced at build time, and this is caused
> by the incorrect use of "qualifier" in the import statement of the
> feature which is not replaced at build time
> <requires>
> <import feature="org.eclipse.ufacekit.core.feature"
> version="1.0.0.qualifier"/>
> </requires>
> So there are two solutions:
> - Include the core.feature in the ui.feature and continue on using the
> qualifier
> - Keep the current structure and remove .qualifier.

Well I guess I'll go with the latter because if I take this further the
includes will pop down even further.

I've just committed the changes let's see what the result will be.

Thanks for your investigation - I'll keep you posted.


B e s t S o l u t i o n . a t                        EDV Systemhaus GmbH
tom schindl                                        geschaeftsfuehrer/CEO
eduard-bodem-gasse 5/1    A-6020 innsbruck      phone    ++43 512 935834