[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Is p2 3.6 compatible with previous p2 versions at p2 repository level?

The plan is to *always* be backward compatible. At this point 3.6 can read 3.5 and 3.4 p2 repos as well as legacy update sites.
However forward compatibility of 3.5 and 3.4 with 3.6 repos will only work if the IUs contained in this repo don't make use of advanced new functionalities introduced in 3.6 (e.g. arity on requirement, or complex IExpression in requirements).
The work on serialization of 3.6 content is still to be done: https://bugs.eclipse.org/bugs/show_bug.cgi?id=298932

PaScaL

Inactive hide details for Vlad Tatavu ---14/01/2010 10:33:30 AM---Hi,Vlad Tatavu ---14/01/2010 10:33:30 AM---Hi,


From:

Vlad Tatavu <vtatavu@xxxxxxxxxxxx>

To:

P2 developer discussions <p2-dev@xxxxxxxxxxx>

Date:

14/01/2010 10:33 AM

Subject:

[p2-dev] Is p2 3.6 compatible with previous p2 versions at p2 repository level?




Hi,

Are p2 repository created using previous versions of p2 compatible with
p2 3.6?
Are p2 repositories created using p2 3.6 compatible with previous
versions of p2?

Best regards,
Vlad
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


GIF image

GIF image