[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] Issue running p2 director

The short answer is no. There is no mechanism to install all the elements found in a category and there is no problem with the EMF repo.

The top level node you select in the UI is a category. It is a user-focused grouping mechanism that allows for "better / easier" presentation of content when browsing a repository. The fact that such a category is selectable in the UI is a result of backward compatibility behaviour with the previous Eclipse Update Manager. To me this has always been a weird thing to select a group, since it may contains things that are incompatible with each others. When you go to the grocery store in the past alley, do you buy a package of each sort of pasta?




Inactive hide details for RE: [p2-dev] Issue running p2 directorRE: [p2-dev] Issue running p2 director




RE: [p2-dev] Issue running p2 director

Dalton, Tom

to:

P2 developer discussions

09/11/2009 09:47 AM


Sent by:

p2-dev-bounces@xxxxxxxxxxx
Please respond to P2 developer discussions





I have one more slightly-related question. I am installing the features from the EMP .zip update site by using org.eclipse.emf.feature.group and org.eclipse.xsd.feature.group. However, when I run up eclipse and look at the installed plugins, not everything from the site is installed. I can go back and manually point the UI at the zip and install the extra components, but I don't understand how/why the feature groups don't pick up all the features - all features in the site .zip are org.eclipse.emf.* or org.eclipse.xsd.*

Is this another bug in the EMF site? As a workaround, rather than have to specify every feature to be installed one by one, is it possible to tell P2 director to install every feature from the site, mirroring the UI behaviour as if you click the top-level group in the "feature tree"?

Thanks for your help so far!

Tom




From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Dalton, Tom
Sent:
11 September 2009 12:27
To:
P2 developer discussions
Subject:
RE: [p2-dev] Issue running p2 director

GIF image

GIF image

GIF image

GIF image