[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] unable to update feature patch

On Mon, Aug 17, 2009 at 10:41:25AM -0700, Andrew Eisenberg wrote:
> I am not explicitly trying to update JDT.  I am checking only the
> groovy update site, which contains a patch for JDT core.  The patched
> version of JDT core to install  is higher than the patched version
> already installed.  Perhaps P2 is trying to update JDT behind the
> scenes for some reason?

It looks to me like it's trying to update the product, too.  See all
the 3.5.0 to 3.5.9 versions?

I think something installed, probably the product, depends on the
installed version of JDT.  Then something - presumably your plugin -
is causing p2 to pull in the later JDT.

-- 
Daniel Jacobowitz
CodeSourcery