[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Re: unable to update feature patch

I haven't heard back from anyone on this.  We consider this to be a
major problem that we are having.  Is there a better place to ask this
question, or should I raise a bug for this?

thank you,
--andrew

On Fri, Aug 14, 2009 at 10:23 AM, Andrew Eisenberg<andrew@xxxxxxxxxxxx> wrote:
> Hi all,
>
> My product includes a feature patch for JDT.  We are able to create it
> without problems and people are able to use it without problems.
>
> The issue is when users try to update the feature patch (see below).
> P2 is refusing to allow the update.  Could it be that because the
> product does not include the original (unpatched) JDT, P2 is not
> allowing the update to proceed?
>
> Any idea how to address this problem?
>
> thanks,
> --andrew
>
>
> Your original request has been modified.
>  "Groovy-Eclipse Feature" is already installed, so an update will be
> performed instead.
>  "JDT Core patch for Groovy-Eclipse plugin" is already installed, so
> an update will be performed instead.
> Cannot complete the install because of a conflicting dependency.
>  Software being installed: Groovy-Eclipse Feature
> 2.0.0.20090811-1500-e35
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.20090811-1500-e35)
>  Software currently installed: SpringSource Tool Suite
> 2.1.0.200908052147-SR01 (com.springsource.sts.ide
> 2.1.0.200908052147-SR01)
>  Only one of the following can be installed at once:
>    JDT Core patch for Groovy-Eclipse plugin 2.0.0.20090804-1900-e35-N
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.20090804-1900-e35-N)
>    JDT Core patch for Groovy-Eclipse plugin 2.0.0.20090811-1500-e35
> (org.codehaus.groovy.jdt.patch.feature.jar 2.0.0.20090811-1500-e35)
>  Only one of the following can be installed at once:
>    Java Development Tools Core 3.5.0.v_963 (org.eclipse.jdt.core 3.5.0.v_963)
>    Java Development Tools Core 3.5.9.20090811-1500-e35
> (org.eclipse.jdt.core 3.5.9.20090811-1500-e35)
>    Java Development Tools Core 3.5.9.20090804-1900-e35-N
> (org.eclipse.jdt.core 3.5.9.20090804-1900-e35-N)
>  Cannot satisfy dependency:
>    From: SpringSource Tool Suite 2.1.0.200908052147-SR01
> (com.springsource.sts.ide 2.1.0.200908052147-SR01)
>    To: com.springsource.sts.package.feature.group [2.1.0.200908052147-SR01]
>  Cannot satisfy dependency:
>    From: SpringSource Tool Suite 2.1.0.200908052147-SR01
> (com.springsource.sts.package.feature.group 2.1.0.200908052147-SR01)
>    To: org.eclipse.jdt.feature.group [3.5.0,4.0.0)
>  Cannot satisfy dependency:
>    From: Groovy-Eclipse Feature 2.0.0.20090811-1500-e35
> (org.codehaus.groovy.eclipse.feature.feature.group
> 2.0.0.20090811-1500-e35)
>    To: org.codehaus.groovy.jdt.patch.feature.group [2.0.0.20090811-1500-e35]
>  Cannot satisfy dependency:
>    From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.20090804-1900-e35-N (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.20090804-1900-e35-N)
>    To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.20090804-1900-e35-N]
>  Cannot satisfy dependency:
>    From: JDT Core patch for Groovy-Eclipse plugin
> 2.0.0.20090811-1500-e35 (org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.20090811-1500-e35)
>    To: org.codehaus.groovy.jdt.patch.feature.jar [2.0.0.20090811-1500-e35]
>  Cannot satisfy dependency:
>    From: Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
> (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>    To: org.eclipse.jdt.core [3.5.0.v_963]
>  Cannot satisfy dependency:
>    From Patch: org.codehaus.groovy.jdt.patch.feature.group
> 2.0.0.20090811-1500-e35 Eclipse Java Development Tools
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1
> (org.eclipse.jdt.feature.group
> 3.5.0.v20090527-2000-7r88FEeFJePyvYeA33DjZ_c1)
>    To: org.eclipse.jdt.core [3.5.9.20090811-1500-e35]
>