[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] External upgrades

The director can be used for platform upgrades, however, 3.4 cannot be upgraded to 3.5.  (Some new things were added to the metadata that 3.4 doesn't understand).  Having said that, you might be able to use a 3.5 director to upgrade from 3.4 to 3.5. 

Has anybody tried that?

cheers,
ian

On Tue, Jul 14, 2009 at 10:37 AM, Daniel Jacobowitz <drow@xxxxxxxxx> wrote:
On Tue, Jul 14, 2009 at 10:07:43AM -0700, Ian Bull wrote:
> For upgrading eclipse using p2, have you tried the director application?
> You can use a repository, point to an Eclipse install, and upgrade the
> install.

Yes, I'm familiar with the director.  Can it actually be used for
platform upgrades, e.g. 3.4 to 3.5?

If so, I've got an upgrade strategy - it introduces a lot of potential
errors that we didn't have with EUM, but it'll work.  Our installer
will have to install an upgrade site and run the director, instead of
replacing any files in the Eclipse installation.

--
Daniel Jacobowitz
CodeSourcery
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev



--
R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
http://eclipsesource.com | http://twitter.com/eclipsesource