[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Why Mail RCP cloud P2 demo self update failed?

I am trying to study the Mail RCP cloud example in P2. But I failed to
P2 self update
the mail demo. Could somebody tell me how to config mail demo so it
knows there is a new version in repository?

Here is what I did:

1. Checkout p2 source codes and p2 example source codes, build and export fine.

2. Export cloud.product into /tmp/repo, The p2 repository is created
under /tmp/repo/repository

3. Changed the version of cloud.product to 1.0.1, Changed the version of plugin
org.eclipse.equinox.p2.examples.rcp.cloud to 1.0.1
Re-export cloud.product into /tmp/repo

Now the p2 repository /tmp/repo/repository contains both 1.0.0 and
1.0.1 of mail rcp cloud product.

4. I use the following script to install 1.0.0 of the mail rcp cloud
successfully.

		<exec executable="java" failonerror="false" dir="${rt.dir}" timeout="900000">
			<arg line="-Declipse.p2.data.area=d:\tmp\p2maildemo\eclipse/p2" />
			<arg line="-Xdebug" />
			<arg line="-jar org.eclipse.equinox.launcher_1.0.200.N20090318-2000.jar" />
			<arg line="-application org.eclipse.equinox.p2.director.app.application" />
			<arg line="-nosplash" />
			<arg line="--launcher.suppressErrors" />
			<arg line="-consoleLog" />
			<arg line="-flavor tooling" />
			<arg line="-installIU org.eclipse.equinox.p2.examples.rcp.cloud.product" />
			<arg line="-version 1.0.0.qualifier"/>
			<arg line="-p2.os win32" />
			<arg line="-p2.ws win32" />
			<arg line="-p2.arch x86" />
			<arg line="-roaming" />
			<arg line="-profile p2maildemo" />
			<arg line="-profileProperties org.eclipse.update.install.features=true" />
			<arg line="-metadataRepository http://localhost:8080/p2maildemo"; />
			<arg line="-artifactRepository http://localhost:8080/p2maildemo"; />
			<arg line="-destination d:\tmp\p2maildemo\eclipse" />
			<arg line="-bundlepool d:\tmp\p2maildemo\eclipse" />
		</exec>

5. Launch mail demo, everything looks fine, except when I click 'Check
for Update', it says 'nothing to update'.
I also tried to modify p2.inf and copy that file into META-INF. I got
the same result 'nothing to update'.

Thanks a lot.