[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] configuration/org.eclipse.update?

Ciao Pascal :)
re 1: we'll look at this...
re 2: we had a product based on plug-ins. basing it on features and
setting the property to true gets us a step further, however, this will
result in problems getting ecf into the profile since no feature
"includes" them. We'll continue from there and see where we get though,
thanks for the pointer! :) 

So, the result is "links" and "dropins" support is disabled if one bases
a product on plug-ins, guess that's worth a bz?
HTH,
Ciao, hh

-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On
Behalf Of Pascal Rapicault
Sent: Wednesday, May 06, 2009 3:55 AM
To: P2 developer discussions
Cc: P2 developer discussions; p2-dev-bounces@xxxxxxxxxxx
Subject: Re: [p2-dev] configuration/org.eclipse.update?

1) I suspect that you did not get the CUs associated with the bundles.
Do you see anything CU associated with those two bundles in the profile
resulting from the install and even referred to from the top level IU
you are installing
2) Do you create your profile setting the
org.eclipse.update.install.features profile property to true?

Inactive hide details for "Haigermoser, Helmut" ---05/05/2009 10:10:13
AM---Ciao Guys :)"Haigermoser, Helmut" ---05/05/2009 10:10:13 AM---Ciao
Guys :)



From:	
"Haigermoser, Helmut" <Helmut.Haigermoser@xxxxxxxxxxxxx>	

To:	
"P2 developer discussions" <p2-dev@xxxxxxxxxxx>	

Date:	
05/05/2009 10:10 AM	

Subject:	
[p2-dev] configuration/org.eclipse.update?	
________________________________




Ciao Guys :)
We're trying to rebuild the platform (product) with some additional
plug-ins and run into a difference when using the director compared to
the result we can download as a platform zip:
1.) start levels: the official platform product has the "reconciler" at
"1,True" and the old update at "1,False", we get the opposite
2.) platform.xml: The eclipse.org version ships a file
"configuration/org.eclipse.update/platform.xml", we don't' get that

Are these bugs or are there some special flags we are missing?
TIA,
Ciao, hh
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev