[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] upack attribute

Pascal answered this question this morning and I don't have a problem with the existing behavior. If you use the wizards it always defaults to packed. I have added a note to bug 269128

Inactive hide details for John Arthorne ---05/01/2009 09:32:43 AM---I looked through some of the code this morning, and it doesJohn Arthorne ---05/01/2009 09:32:43 AM---I looked through some of the code this morning, and it does seem to default to unpack=true in the code. This seems to be the ca


From:

John Arthorne <John_Arthorne@xxxxxxxxxx>

To:

P2 developer discussions <p2-dev@xxxxxxxxxxx>

Date:

05/01/2009 09:32 AM

Subject:

Re: [p2-dev] upack attribute





I looked through some of the code this morning, and it does seem to default to unpack=true in the code. This seems to be the case in both UM (PluginEntrryModel.unpack=true) and in the publisher (FeatureEntry.unpack=true). Can you describe the scenario where you see the problem? I.e., are you installing from an old-style update site, generating metadata via the publisher, or what? I just want to make sure there isn't an unintentional bug here.



James D Miles <jdmiles@xxxxxxxxxx>
Sent by: p2-dev-bounces@xxxxxxxxxxx

04/30/2009 03:08 PM

Please respond to
P2 developer discussions <p2-dev@xxxxxxxxxxx>
To
p2-dev@xxxxxxxxxxx
cc
Subject
[p2-dev] upack attribute




The feature manifest has a "unpack" attribute on the plugin element. According to the DTD the default is true. But what happens is the opposite. Is this a bug for the code or the doc?
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


GIF image

GIF image