[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Replacement for policy.xml?

Hi - I must apologise in advance for the noobie question, but I am struggling to get my head round this problem.

I've got a customised version of the Eclipse IDE that I want to upgrade to Eclipse 3.4. I made the customised version by creating a product and then listing all the features for that product (90% third party, some internal). The features add up to about 20 individual update site locations. 

I made a customised version because I want to control exactly which updates are available to the user, so they can only install items from our intranet. To achieve this in the old version of my app, all I had to do was make these entries in plugin_customization.ini:

org.eclipse.update.core/org.eclipse.update.core.checkSignature=false
org.eclipse.update.core/org.eclipse.update.core.updateVersions=equivalent
org.eclipse.update.core/updatePolicyURL=http://pathtomy/policy.xml
org.eclipse.update.scheduler/download=true
org.eclipse.update.scheduler/enabled=true
org.eclipse.update.scheduler/day=Every day

Then my policy.xml just had a line <url-map pattern="*" url="http://pathtomyupdate/site"/>

This works great. But the question is, how would I achieve the same thing using P2? 

I found this note about policy.xml being obsolete for P2: http://wiki.eclipse.org/Using_Policy_Files which says if you are in control of the repo, you can remove the mirroring information to make the site unaware of any remote mirrors. Now I'm assuming that "repo" = "update site" here, but won't that only work for my own features, not the external ones? The other option is to set -Declipse.p2.mirrors=false which is very easy to do, but does that mean it will not find my own updates either?

I tried creating the product for 3.4, and what happens is when the app starts up, it automatically starts looking for updates (which is what I want, except its also searching external sites). And yet, when I opened the preferences page, the "Automatically find new updates" checkbox is not ticked!? Also, when I try to open the "Software Updates" dialog it tells me that the installation has not been configured properly for software updates.

Any help appreciated. I'm confused!

Thanks,

Doug