[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] Configure Products via P2

Ian,

Bugz item has been created.
* https://bugs.eclipse.org/bugs/show_bug.cgi?id=272602


-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx on behalf of Ian Bull
Sent: Thu 4/16/2009 4:21 PM
To: P2 developer discussions
Subject: Re: [p2-dev] Configure Products via P2
 
So a few things have happened recently.  PDE was recently changed to use the
publisher (instead of the generator), so there might still be outstanding
issues around p2.inf files.  Can you file a bug with this information. I'm
not sure if it's p2 or PDE build, but you can put it in the p2 inbox for now
and either Andrew or I will try and reproduce this.

cheers,
ian


On Thu, Apr 16, 2009 at 1:00 PM, O'Flynn, Dennis <
Dennis.OFlynn@xxxxxxxxxxxxx> wrote:

>  Ian,
>
>
>
> I have updated my IDE to eclipse-SDK-I20090414-0800.  I have also setup my
> headless PDE Build to use releng.basebuilder vI20090415-1348.
> Unfortunately, upgrading to the latest builds did not seem to support
> product def'n with an associated p2.inf.
>
>
>
> An interesting note.  I also tried to provide this configuration
> information within a feature's META-INF/p2.inf.  This did not have any
> effect.  However, when I moved the p2.inf to the root of the feature folder,
> it causes an error in the packaging step:
> org.eclipse.pde.build_3.5.0.v20090413\scripts\genericTargets.xml:218: Java
> returned: 13
>
>
>
> Any ideas?
>
>
>
> I'll keep trying to figure this out as well.
>
>
>
> *From:* p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] *On
> Behalf Of *Ian Bull
> *Sent:* Tuesday, April 14, 2009 12:04 PM
> *To:* P2 developer discussions
> *Subject:* Re: [p2-dev] Configure Products via P2
>
>
>
> What version of p2 are you using?  The p2.inf stuff is very new (within the
> past few weeks) and there may be outstanding issues with it.  If you could
> try with recent IBuilds [1] and report your findings that would be a great
> help.
>
>
> [1] http://download.eclipse.org/eclipse/downloads/
>
> cheers,
> ian
>
> On Tue, Apr 14, 2009 at 6:06 AM, O'Flynn, Dennis <
> Dennis.OFlynn@xxxxxxxxxxxxx> wrote:
>
> Can someone point me to an example and/or additional information on how to
> configure a product using p2?
>
>
>
> I have been following the comments posted at
> http://wiki.eclipse.org/Equinox/p2/GeneratingCUs#Configuring_Products.  I
> have a p2.inf co-located with the .product file.  However the touchpoint
> advice doesn't seem to be processed.
>
>
>
> I need to specify additional plug-ins to be started.  Any suggestions would
> be greatly appreciated.
>
> Dennis O'Flynn
> Technical Consultant
> [image: compuware]
> One Campus Martius
> 12W-1104
> Detroit, Michigan 48226
> 313-227-7433 Work
> 313-227-9230 Fax
>
>
>
>
> The contents of this e-mail are intended for the named addressee only. It
> contains information that may be confidential. Unless you are the named
> addressee or an authorized designee, you may not copy or use it, or disclose
> it to anyone else. If you received it in error please notify us immediately
> and then destroy it.
>
>
> _______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev
>
>
>
>
> --
> R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
> http://eclipsesource.com | http://twitter.com/eclipsesource
>
> _______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev
>
>


-- 
R. Ian Bull | EclipseSource Victoria | +1 250 477 7484
http://eclipsesource.com | http://twitter.com/eclipsesource

<<winmail.dat>>