[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] publishing a product from source, headlessly

Ciao Andrew :)
Ah, thanks !:)
I'm trying things with April 1st' I-build now! :)
Using p2.gathering=true I'm getting past the generation into the
director phase! :) The implicit director calls are still failing as I
write this (java returned exit 13). This gets me to todays question, is
there any place I can look for director output in such a case? (Took me
some time running the director by hand on the p2.gathering-generated
repos so that I could see my product had failed dependencies...)

Anyway, keep up the great work and improvements! :)
Helmut 

-----Original Message-----
From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On
Behalf Of Andrew Niefer
Sent: Friday, April 03, 2009 4:24 PM
To: P2 developer discussions
Subject: Re: [p2-dev] publishing a product from source, headlessly


Helmut,
You are hitting https://bugs.eclipse.org/bugs/show_bug.cgi?id=269540
(which causes 269322).  This was fixed in the IBuild after M6. 

-Andrew 



"Haigermoser, Helmut" <Helmut.Haigermoser@xxxxxxxxxxxxx>
Sent by: p2-dev-bounces@xxxxxxxxxxx 

04/01/2009 12:47 PM
Please respond to
P2 developer discussions <p2-dev@xxxxxxxxxxx>

To
"P2 developer discussions" <p2-dev@xxxxxxxxxxx> cc Subject [p2-dev]
publishing a product from source, headlessly

	




Hi @ll :)
Just tried using 3.5 M6 to create an RCP but got stuck somehow. 
Thought I'd ask before spending too much time trying to find the right
way,
so here is what I did in 3.4                 

1.) Build the product (modify build.properties with all the
generate.p2.metadata properties) based on my .product
2.) Install from the generated repo to get a roaming, usable profile for
my RCP

>From eclipseCon I seem to remember some changes:
- pde now builds all at once (combining my two steps)
- have only a single property (can't remember which one)

Looks like my 3.4 setup succeeds in building my 3.5 code just fine (i.e.
without any changes), but does not finish the assembly phase
successfully:
.
.
.
BUILD FAILED
plugins/org.eclipse.pde.build/scripts/productBuild/productBuild.xml:32:
The following error occurred while executing this line:
plugins/org.eclipse.pde.build/scripts/build.xml:115: The following error
occurred while executing this line:
plugins/org.eclipse.pde.build/templates/headless-build/customTargets.xml
:12: The following error occurred while executing this line:
plugins/org.eclipse.pde.build/scripts/productBuild/allElements.xml:10:
The following error occurred while executing this line:
plugins/org.eclipse.pde.build/scripts/genericTargets.xml:182: The
following error occurred while executing this line:
/tmp/release_010409_18_39_35/build/package.org.eclipse.pde.build.contain
er.feature.all.xml:23: The following error occurred while executing this
line:
/tmp/release_010409_18_39_35/build/package.org.eclipse.pde.build.contain
er.feature.all.xml:15: The following error occurred while executing this
line:
plugins/org.eclipse.pde.build/scripts/productBuild/allElements.xml:44:
The following error occurred while executing this line:
/tmp/release_010409_18_39_35/build/package.org.eclipse.pde.build.contain
er.feature.win32.win32.x86.xml:96: java.io.EOFException

Removing my custom launcher name from the product helps a bit here but I
thought I'd stop experimenting at this point and ask for directions,
maybe the whole process changed and I need not try to fix these
issues...

Tried searching the docs but there is not much there yet, any help is
appreciated! :) Helmut _______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev