[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] publishing a product from source, headlessly

I assume Andrew's blog entry is now the bible on this stuff, no?

http://aniefer.blogspot.com/2009/03/building-p2-rcp-products-in-eclipse.
html

Doug. 

> -----Original Message-----
> From: p2-dev-bounces@xxxxxxxxxxx 
> [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Haigermoser, Helmut
> Sent: Wednesday, April 01, 2009 12:48 PM
> To: P2 developer discussions
> Subject: [p2-dev] publishing a product from source, headlessly
> 
> Hi @ll :)
> Just tried using 3.5 M6 to create an RCP but got stuck somehow. 
> Thought I'd ask before spending too much time trying to find 
> the right way,
> so here is what I did in 3.4	
> 
> 1.) Build the product (modify build.properties with all the 
> generate.p2.metadata properties) based on my .product
> 2.) Install from the generated repo to get a roaming, usable 
> profile for my RCP
> 
> >From eclipseCon I seem to remember some changes:
> - pde now builds all at once (combining my two steps)
> - have only a single property (can't remember which one)
> 
> Looks like my 3.4 setup succeeds in building my 3.5 code just 
> fine (i.e.
> without any changes), but does not finish the assembly phase
> successfully:
> .
> .
> .
> BUILD FAILED
> plugins/org.eclipse.pde.build/scripts/productBuild/productBuil
> d.xml:32:
> The following error occurred while executing this line:
> plugins/org.eclipse.pde.build/scripts/build.xml:115: The 
> following error occurred while executing this line:
> plugins/org.eclipse.pde.build/templates/headless-build/customT
> argets.xml
> :12: The following error occurred while executing this line:
> plugins/org.eclipse.pde.build/scripts/productBuild/allElements.xml:10:
> The following error occurred while executing this line:
> plugins/org.eclipse.pde.build/scripts/genericTargets.xml:182: 
> The following error occurred while executing this line:
> /tmp/release_010409_18_39_35/build/package.org.eclipse.pde.bui
> ld.contain
> er.feature.all.xml:23: The following error occurred while 
> executing this
> line:
> /tmp/release_010409_18_39_35/build/package.org.eclipse.pde.bui
> ld.contain
> er.feature.all.xml:15: The following error occurred while 
> executing this
> line:
> plugins/org.eclipse.pde.build/scripts/productBuild/allElements.xml:44:
> The following error occurred while executing this line:
> /tmp/release_010409_18_39_35/build/package.org.eclipse.pde.bui
> ld.contain
> er.feature.win32.win32.x86.xml:96: java.io.EOFException
> 
> Removing my custom launcher name from the product helps a bit 
> here but I thought I'd stop experimenting at this point and 
> ask for directions, maybe the whole process changed and I 
> need not try to fix these issues...
> 
> Tried searching the docs but there is not much there yet, any 
> help is appreciated! :) Helmut 
> _______________________________________________
> p2-dev mailing list
> p2-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/p2-dev
>