[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] pack200, JRE versions requirements

I am looking into potential issues using (and creating) pack 200 jars (artifacts).

I believe that packing code for a particular JRE version (as per.class files compatibility) requires pack200 and unpack200 from at least that JRE version. https://bugs.eclipse.org/bugs/show_bug.cgi?id=141195#c3 suggests that there may be a dependency on the particular parameters used in pack200 as well.
What is the latest on this?

Also does unpack200 must be of the same or higher JRE version as the pack200 used during packing? For example if the jar processing was done with JDK 1.5 is the unpacker required to be from the 1.5 version? If so is any JRE service release (expected to be compatible)?

Are there other potential pitfalls to watch out for?

For the each pluging which will be produced for the 3.5 update site how is the following specified:
- the jre version to use
- pack 200 parameters
- whether it should be packed at all.
Will different jars be packed with different pack200 versions?

Thanks,

Henrich