[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Problem with p2 repo in dropins

I noticed that your zip contains a p2 metadata repo but not an artifact repo (e.g. content.xml but not an artifacts.xml). That's likely the problem and the right way to fix the problem is to also generate the artifact repo and have that in your repo.
As to why it worked in 3.4, there was a bug where we detected the wrong kind of repo and totally ignored the content.xml and loaded the repo as an eclipse extension instead.

-Simon

Inactive hide details for Alexander Kurtakov ---03/20/2009 11:14:28 AM---Hi everyone,Alexander Kurtakov ---03/20/2009 11:14:28 AM---Hi everyone,


From:

Alexander Kurtakov <akurtako@xxxxxxxxxx>

To:

p2-dev@xxxxxxxxxxx

Date:

03/20/2009 11:14 AM

Subject:

[p2-dev] Problem with p2 repo in dropins




Hi everyone,
I've got a problem with recognizing p2 repos in dropins folder.
You can easyily reproduce it by just extracting
http://akurtakov.fedorapeople.org/moreunit.tar.bz2 in the dropins folder of
3.5 M6 and see that it won't be recongnised as a repository :
org.eclipse.equinox.internal.provisional.p2.core.ProvisionException: No
repository found at
file:..../dropins/moreunit/.
Does it mean that p2 repos in dropins are not supported anymore? Or I should
file a bug about it?
This worked fine in Eclipse 3.4.

Thanks for any help,
Alexander Kurtakov
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


GIF image

GIF image