[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Regression?

Hi James,
The translation from 1.0.0 equivalent used in the feature.xml to the range [1.0.0,1.1.0) seems correct. Can you see what version (if any) of com.test.pAarB.feature that is available when the install fails?

Regards,
Thomas Hallgren

James D Miles wrote:

I am working with M6 and I am seeing the following error

    Cannot complete the install because one or more required items could not be found.
    Software being installed: com.test.pluginA.feature.feature.group 1.0.0.200903171644
    Missing requirement: com.test.pluginA.feature.feature.group 1.0.0.200903171644 requires 'com.test.pArB.feature.feature.group [1.0.0,1.1.0)' but it could not be found
If I use a site I generated with a prior SDK build it works.

This is a simple feature requires for featureA
- <requires> <import feature="com.test.pArB.feature" version="1.0.0" match="equivalent" /> </requires>

Is there a bug for this?

_______________________________________________ p2-dev mailing list p2-dev@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/p2-dev