[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] P2 Installer fails due to what seems to be an incorrect dependency from eclipse touchpoint to publisher?

Hi,

I'm playing around with the p2 installer, and it appears it's (since
at least M5, I just tried it with the integration build I20090310-0100
as well) unable to load the eclipse touchpoint due to a missing class
(org.eclipse.equinox.p2.publisher.IPublisherAdvice). I inspected the
eclipse touchpoint plugin, which has a new Import-Package in M5
(compared to M3, didn't check M4) referencing
org.eclipse.equinox.p2.publisher, however the resolution is optional,
and the installer does not contain this plugin. Should the resolution
perhaps be mandatory (i.e. default) and included in the installer?

Or have I messed something up?

Thanks,
Fredrik.