[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo

Hi Andrew,
 
I re-jigged my mirror script to mirror the Ganymede metadata then the Ganymede artifacts and hit the same problem: the mirror did not contain content.jar/xml. However, I did get 1943 artifacts.
 
I am not sure what I do now. Please advise.
 
Miles Daffin
Morgan Stanley | Technology
20 Cabot Square | Canary Wharf | Floor 01
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572
Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Andrew Cattle
Sent: 25 November 2008 21:09
To: P2 developer discussions
Subject: RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo


Hi, I've been looking at this for a while and I really am sorry we haven't been able to find a resolution sooner. We have some ideas about how to fix this behaviour you've been experiencing but unfortunately we've been very busy as of late.

I've just looked at the code and right now my best guess is p2 is incorrectly interpretting your artifact repository as a type of metadata repository. As a temporary work around could you please delete your destination (or simply create a new, empty destination) and then perform the metadata mirroring BEFORE the artifact mirroring.

Here's my results (note that C:\tmp did not exist before running this command):

<eclipse install>>eclipse.exe -application org.eclipse.equinox.p2.metadata.repository.mirrorApplication -source http://download.eclipse.org/releases/ganymede/ -destination file:c:/tmp

This resulted in 2436 units, the same number as in the downloaded content.jar. I noted that the target repository does not have the "referenced repositories" of the source, but this is not an issue if you plan to use the source for internal use only.

<eclipse install>>eclipse.exe -application org.eclipse.equinox.p2.artifact.repository.mirrorApplication -source http://download.eclipse.org/releases/ganymede/ -destination file:c:/tmp -ignoreErrors

This resulted in 1941 artifacts, compared to an expected 1943 artifacts.



"Daffin, Miles \(IT\)" <Miles.Daffin@xxxxxxxxxxxxxxxxx>
Sent by: p2-dev-bounces@xxxxxxxxxxx

11/25/2008 11:14 AM

Please respond to
P2 developer discussions <p2-dev@xxxxxxxxxxx>

To
"P2 developer discussions" <p2-dev@xxxxxxxxxxx>
cc
Subject
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo





Folks,
 
Has anyone had time to look at this? I ran another test on the Ganymede repo:
 
http://download.eclipse.org/releases/ganymede/
 
This time I got a features dir with features, a plugins dir with plugins and an artifacts.jar file - but no content.jar.
 
Cheers,
 
Miles Daffin
Morgan Stanley | Technology

20 Cabot Square | Canary Wharf | Floor 01
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572

Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Daffin, Miles (IT)
Sent:
18 November 2008 17:51
To:
P2 developer discussions
Subject:
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo


Folks,
 
I have just tried using the 3.5M3 version of the mirroring applications to mirror the eclipse repo: http://download.eclipse.org/eclipse/updates/3.4. The mirror op seemed to complete normally (if rather quickly - 59 seconds). When I looked in the destination directory this is what I saw:
 
* artifacts.jar
* plugins (dir, empty)
 
I ran the applications as documented here: http://help.eclipse.org/ganymede/topic/org.eclipse.platform.doc.isv/guide/p2_mirror.html.
 
I was expecting a full mirror: features, plugins, artifacts.jar, content.jar. Was I wrong to expect this?
 
The output from running the applications (done using ant) is below. I noted the warning message: "Retry another mirror". I did this a couple of times with other mirrors in this list:
 
http://www.eclipse.org/downloads/download.php?file=/eclipse/updates/3.4&format=xml
 
The result was the same.
 
The output from running the applications is below. Am I doing something wrong? Please advise. (I am getting rather desperate :)
 
Thanks,
 
Miles
 
----------
 
[build-log] Mirroring p2 repository (v2):
[build-log]  - source:
http://download.eclipse.org/eclipse/updates/3.4
[build-log]  - dest  : C:\dev\shadow\eclipseide\update-eclipse\trunk\src/site
[build-log]  - name  : MSDE Mirror: Eclipse Project Repository
  [delete] Deleting directory C:\dev\shadow\eclipseide\update-eclipse\trunk\src\site
   [mkdir] Created dir: C:\dev\shadow\eclipseide\update-eclipse\trunk\src\site
[build-log]
[build-log] Mirroring artifacts from
http://download.eclipse.org/eclipse/updates/3.4 to C:\dev\shadow\eclipseide\update-eclipse\trunk\src/site
    [exec] Install location:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/
    [exec] Configuration file:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/configuration/config.ini loaded
    [exec] Configuration location:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/configuration/
    [exec] Framework located:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/plugins/org.eclipse.osgi_3.5.0.v20081027-1700.jar
    [exec] Framework classpath:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/plugins/org.eclipse.osgi_3.5.0.v20081027-1700.jar
    [exec] Splash location:
    [exec]     null
    [exec] Debug options:
    [exec]     file:/C:/dev/shadow/eclipseide/update-eclipse/trunk/src/.options not found
    [exec] Time to load bundles: 16
    [exec] Starting application: 2343
    [exec] Mirroring: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.1.R34x_v20080819 (Descriptor: packed: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.1.R
34x_v20080819)
    [exec] Mirroring: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.1.R34x_v20080819 (Descriptor: canonical: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.
1.R34x_v20080819)
    [exec] Mirroring: org.eclipse.ltk.ui.refactoring.source/osgi.bundle/3.4.0.v20080605-1800 (Descriptor: canonical: org.eclipse.ltk.ui.refactoring.source/osgi.bundle/3.4.0.v20080
605-1800)
    [exec] Mirroring: org.eclipse.ltk.ui.refactoring.source/osgi.bundle/3.4.0.v20080605-1800 (Descriptor: packed: org.eclipse.ltk.ui.refactoring.source/osgi.bundle/3.4.0.v20080605
-1800)
    [exec] Mirroring: org.eclipse.swt.wpf.win32.x86.source/osgi.bundle/3.4.1.v3449c (Descriptor: packed: org.eclipse.swt.wpf.win32.x86.source/osgi.bundle/3.4.1.v3449c)
    [exec] Retry another mirror
    [exec] Start VM:
\\ms\dist\msjava\PROJ\sunjdk\1.6.0_04\jre/bin/javaw.exe
    [exec] -jar C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
    [exec] -os win32
    [exec] -ws win32
    [exec] -arch x86
    [exec] -showsplash
    [exec] -launcher C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\eclipse.exe
    [exec] -name Eclipse
    [exec] --launcher.library C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20080731-1
700\eclipse_1200.dll
    [exec] -startup C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
    [exec] -exitdata 1680_1fa8
    [exec] -application org.eclipse.equinox.p2.artifact.repository.mirrorApplication
    [exec] -source
http://download.eclipse.org/eclipse/updates/3.4
    [exec] -destination file:C:\dev\shadow\eclipseide\update-eclipse\trunk\src/site/
    [exec] -verbose
    [exec] -debug
    [exec] -vm
\\ms\dist\msjava\PROJ\sunjdk\1.6.0_04\jre/bin/javaw.exe
    [exec] -vmargs
    [exec] -jar C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
[build-log] Mirror artifacts complete!
[build-log]
[build-log] Mirroring metadata from
http://download.eclipse.org/eclipse/updates/3.4 to C:\dev\shadow\eclipseide\update-eclipse\trunk\src/site
    [exec] Install location:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/
    [exec] Configuration file:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/configuration/config.ini loaded
    [exec] Configuration location:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/configuration/
    [exec] Framework located:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/plugins/org.eclipse.osgi_3.5.0.v20081027-1700.jar
    [exec] Framework classpath:
    [exec]     file:/c:/dev/shadow/eclipseide/update-eclipse/trunk/build/equinox-p2-agent/plugins/org.eclipse.osgi_3.5.0.v20081027-1700.jar
    [exec] Splash location:
    [exec]     null
    [exec] Debug options:
    [exec]     file:/C:/dev/shadow/eclipseide/update-eclipse/trunk/src/.options not found
    [exec] Time to load bundles: 15
    [exec] Starting application: 953
    [exec] Mirroring: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.1.R34x_v20080819 (Descriptor: packed: org.eclipse.equinox.p2.metadata.generator/osgi.bundle/1.0.1.R
34x_v20080819)
    [exec] Retry another mirror
    [exec] Start VM:
\\ms\dist\msjava\PROJ\sunjdk\1.6.0_04\jre/bin/javaw.exe
    [exec] -jar C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
    [exec] -os win32
    [exec] -ws win32
    [exec] -arch x86
    [exec] -showsplash
    [exec] -launcher C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\eclipse.exe
    [exec] -name Eclipse
    [exec] --launcher.library C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20080731-1
700\eclipse_1200.dll
    [exec] -startup C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
    [exec] -exitdata 13fc_1fa8
    [exec] -application org.eclipse.equinox.p2.artifact.repository.mirrorApplication
    [exec] -source
http://download.eclipse.org/eclipse/updates/3.4
    [exec] -destination file:C:\dev\shadow\eclipseide\update-eclipse\trunk\src/site/
    [exec] -verbose
    [exec] -debug
    [exec] -vm
\\ms\dist\msjava\PROJ\sunjdk\1.6.0_04\jre/bin/javaw.exe
    [exec] -vmargs
    [exec] -jar C:\dev\shadow\eclipseide\update-eclipse\trunk\src\..\build\equinox-p2-agent\\plugins/org.eclipse.equinox.launcher_1.0.200.v20080825-1800.jar
[build-log] Mirror metadata complete!

 
Miles Daffin
Morgan Stanley | Technology

20 Cabot Square | Canary Wharf | Floor 01
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572

Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Daffin, Miles (IT)
Sent:
03 November 2008 17:27
To:
P2 developer discussions
Cc:
p2-dev-bounces@xxxxxxxxxxx
Subject:
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo


OK. Found the 3.5 M3 download page, so please disregard the second request unless this is incorrect:
 
http://download.eclipse.org/equinox/drops/S-3.5M3-200810301917/download.php?dropFile=equinox-p2-agent-3.5M3-win32.zip
 
Miles Daffin
Morgan Stanley | Technology

20 Cabot Square | Canary Wharf | Floor 06
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572

Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Daffin, Miles (IT)
Sent:
03 November 2008 17:20
To:
P2 developer discussions
Cc:
p2-dev-bounces@xxxxxxxxxxx
Subject:
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo


Andrew,
 
Is there any way in which I can be notified once the releng people have fixed the repository? I will then try mirroring again using the p2 agent download from the 3.5 m3 release. Please give me the url of the download page for this release. (I have checked the eclipse downloads page and do not see a reference to it.)
 
Thanks,
 
Miles
 
Miles Daffin
Morgan Stanley | Technology

20 Cabot Square | Canary Wharf | Floor 06
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572

Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Pascal Rapicault
Sent:
03 November 2008 14:33
To:
P2 developer discussions
Cc:
P2 developer discussions; p2-dev-bounces@xxxxxxxxxxx
Subject:
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo

The 3.4/3.4.1 artifact repository is missing some artifacts. To be precise, the artifact descriptor is in the artifacts.xml but the corresponding file is not available on disk. This is not a p2 problem but results from some filtering done by the ant script copying the repo from the build machine to the server.
The releng team is looking at fixing this.



Inactive hide details for "Daffin, Miles (IT)" ---03/11/2008 08:25:09 AM---Andrew, The problems I reported were during attempts"Daffin, Miles (IT)" ---03/11/2008 08:25:09 AM---Andrew, The problems I reported were during attempts to mirror the latest version of the eclipse pla


From:

"Daffin, Miles (IT)" <Miles.Daffin@xxxxxxxxxxxxxxxxx>

To:

P2 developer discussions <p2-dev@xxxxxxxxxxx>

Date:

03/11/2008 08:25 AM

Subject:

RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo





Andrew,


The problems I reported were during attempts to mirror the latest version of the eclipse platform repo, which is 3.4.1 I believe (released on September 24th). I need to be able to use p2 mirroring tools to create faithful mirrors of both the eclipse platform and Ganymede repos so that I can release 3.4.1 internally at my company:


Eclipse platform:
http://download.eclipse.org/eclipse/updates/3.4/
Ganymede:
http://download.eclipse.org/releases/ganymede/

Thanks,


Miles Daffin

Morgan Stanley | Technology

20 Cabot Square | Canary Wharf | Floor 06
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572

Miles.Daffin@xxxxxxxxxxxxxxxxx



From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Andrew Cattle
Sent:
03 November 2008 13:15
To:
P2 developer discussions
Subject:
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo



I'm currently not willing to say one way or the other whether this is the cause of the failure, but
"com.ibm.icu.base" is one of the missing packages and not being able to download it seems to be what is causing the catastrophic failure. I'd like to try and get the artifact.xml cleaned up and try testing the bug agian before we decided if that was the problem.

>From the tests I've run I'm willing to say that the problems you're having are most likely related specifically to the 3.4.0 repository. My understanding is that you need to be able to mirror this repository so I'll let you know once we get it working.
_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx

https://dev.eclipse.org/mailman/listinfo/p2-dev




NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.



NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.



NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error._______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev


NOTICE: If received in error, please destroy and notify sender. Sender does not intend to waive confidentiality or privilege. Use of this email is prohibited when received in error.