[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] P2-izing SDK build

Hi,

I'm trying to build 3.4.1 sources and p2-ize it. After running p2
director on my build, there were a few root files missing in the new p2
layout. All I got was eclipse.exe and eclipse.ini in addition to
folders. Below are the steps I took. Am I missing a flag somewhere?

1. I'm building the sdk component with build.xml in eclipsebuilder. All
sources are in our repository, unmodified after being checked out of
eclipse cvs.
2. untar the built archive and generate p2 metadata with this command
line

../../../sun_java/j2sdk1.4.2_14/jre/bin/java -jar
./eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.Test_Build.jar
-data workspace -application
org.eclipse.equinox.p2.metadata.generator.EclipseGenerator -flavor
tooling -metadataRepository "file:../repo" -artifactRepository
"file:../repo" -root "Eclipse SDK" -rootVersion 3.4.1 -source ./eclipse
-append -publishArtifacts -publishArtifactRepository

3. remove all update references to eclipse.org in repo files and
configuration/.settings/*.pref so it doesn't try to access eclipse.org.
3. run p2 director with this command line

../../../sun_java/j2sdk1.4.2_14/jre/bin/java
-Declipse.p2.data.area=./eclipse_p2/p2 -jar
./eclipse/plugins/org.eclipse.equinox.launcher_1.0.101.Test_Build.jar
-data workspace -application
org.eclipse.equinox.p2.director.app.application -flavor tooling
-metadataRepository file:../repo -artifactRepository file:../repo
-installIU "Eclipse SDK" -version 3.4.1 -p2.os linux -p2.ws gtk -p2.arch
x86 -profile SDKProfile -profileProperties
org.eclipse.update.install.features=true -destination ./eclipse_p2
-bundlepool ./eclipse_p2 -consoleLog -roaming 

Any pointers are appreciated. :)

Thanks,
Eirene