[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [p2-dev] Versions that are not OSGi compliant

Feels like an interesting requirement. Some usecases and examples would be helpful. Have you had a chance to look at what the impact of this would be on p2? On the surface you would think that we use versions all over but perhaps it is more isolated...

Jeff

Thomas Hallgren wrote:
Hi,
A while back I brought up the discussion about versions that are not compliant with the standard OSGi format. A brief discussion with Pascal can be viewed here:


http://dev.eclipse.org/mhonarc/lists/equinox-dev/msg04260.html

I also entered a bugzilla

https://bugs.eclipse.org/bugs/show_bug.cgi?id=233699

This issue important to us and as we're moving our technology closer to P2 we would really like to see a resolution. We are of course willing to contribute, partly or in full, if that's what it takes. We have good ideas of how this can be done without any impact on resolution performance. The thing missing at this point is some enthusiastic responses from the p2 team :-)

So what do you think?

Regards,
Thomas Hallgren

_______________________________________________
p2-dev mailing list
p2-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/p2-dev