[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo

Andrew,
 
The problems I reported were during attempts to mirror the latest version of the eclipse platform repo, which is 3.4.1 I believe (released on September 24th). I need to be able to use p2 mirroring tools to create faithful mirrors of both the eclipse platform and Ganymede repos so that I can release 3.4.1 internally at my company:
 
Eclipse platform: http://download.eclipse.org/eclipse/updates/3.4/
Ganymede: http://download.eclipse.org/releases/ganymede/
 
Thanks,
 
Miles Daffin
Morgan Stanley | Technology
20 Cabot Square | Canary Wharf | Floor 06
London, E14 4QW
Phone: +44 20 7677-5119
Fax: +44 20 7056-4572
Miles.Daffin@xxxxxxxxxxxxxxxxx
 


From: p2-dev-bounces@xxxxxxxxxxx [mailto:p2-dev-bounces@xxxxxxxxxxx] On Behalf Of Andrew Cattle
Sent: 03 November 2008 13:15
To: P2 developer discussions
Subject: RE: [p2-dev] P2 Mirror Application fails to mirror Eclipse repo


I'm currently not willing to say one way or the other whether this is the cause of the failure, but "com.ibm.icu.base" is one of the missing packages and not being able to download it seems to be what is causing the catastrophic failure. I'd like to try and get the artifact.xml cleaned up and try testing the bug agian before we decided if that was the problem.

From the tests I've run I'm willing to say that the problems you're having are most likely related specifically to the 3.4.0 repository. My understanding is that you need to be able to mirror this repository so I'll let you know once we get it working.