[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[p2-dev] Cannot install new from update site

The dev update site (http://download.eclipse.org/tools/ajdt/34/dev/update
) for AJDT 1.6 is not working properly.  When there is already a
version of AJDT 1.6 installed in the workspace, updates to the feature
work with no problem.  However, updating from a new installation of
Eclipse 3.4, I get the following problem.

There is a versioning problem somewhere, but I just don't know how to
fix it.  And I don't know where to start looking.  Any pointers would
be appreciated.  Thanks.


Cannot complete the request.  See the details.
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.aspectj.weaver/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.visualiser
2.2.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.aspectj.ajde 1.6.2.20080807114600]
requiredCapability:
osgi.bundle/org.aspectj.weaver/1.6.2.20080807114600
Unsatisfied dependency: [org.aspectj.ajde 1.6.2.20080807114600]
requiredCapability:
osgi.bundle/org.aspectj.weaver/1.6.2.20080807114600
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ajdt.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ajdt.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.contribution.visualiser/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ajdt.mylyn.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.contribution.xref.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.aspectj.weaver/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ajdt.examples/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.feature.group
1.6.0.200808151406] requiredCapability:
org.eclipse.equinox.p2.iu/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.visualiser
2.2.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.examples 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.ajdt.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.core 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.core
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.ajdt.core/1.6.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.contribution.xref.ui/1.5.0
Unsatisfied dependency: [org.eclipse.ajdt.mylyn.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.ajdt.ui/1.6.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.contribution.xref.ui
1.5.0.200808151406] requiredCapability:
osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.ajdt.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.weaver/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.runtime/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.eclipse.contribution.xref.ui/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability:
osgi.bundle/org.eclipse.contribution.xref.core/0.0.0
Unsatisfied dependency: [org.eclipse.ajdt.ui 1.6.0.200808151406]
requiredCapability: osgi.bundle/org.aspectj.ajde/0.0.0
Unsatisfied dependency: [org.aspectj.ajde 1.6.2.20080807114600]
requiredCapability:
osgi.bundle/org.aspectj.weaver/1.6.2.20080807114600