[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [orion-dev] 0.4 M1 available

My best guess is that I am somehow mixing 0.4 and 0.3 by using the same serverworkspace.  Anyway I got things to work again somehow.

jjb

2012/1/9 John J Barton <johnjbarton@xxxxxxxxxxxxxxx>
Somehow I have this same problem again. This time localStorage.clear() + (Shift+Cntrl+R) does not save the day. I have no taskPlugin.html in my plugin list. 

I tried to list the http://localhost:8080/plugins/ to verify if the taskPlugin.html is listed, but that URL fails. I really wish every directory without an index.html would serve a directory listing.

So I'm stuck.  I guess I will reinstall everything.

jjb


2011/12/19 John J Barton <johnjbarton@xxxxxxxxxxxxxxx>
2011/12/19 Malgorzata Tomczyk <Malgorzata.Janczarska@xxxxxxxxxx>:
>> I'm now on another machine. I was unable to get anything to work. So I
>> reinstalled 0.4m1 and erased my serverworkspace. I exited my browser,
>> erased my browser profile. Then I started the server and the browser.
>
> What does "was unable to get anything to work" mean?

Well I meant "I tried to use git-status to fetch and merge so I could
start work, but the page did not load its XHR so I cannot work".

> Did you check
> _javascript_ errors?

Sure, and as usual I had between 3 and 6 errors. But since Orion
always gives errors I don't know what to make of this info.

Later I looked into these errors and as always they involved
defaults.prefs. That's when I connected this problem to Simon's note
on the bugzilla page.

>
>> Just FYI, this problem was probably caused by a bug in preference
>> caching that Simon found.
>
> You did plenty of mess in your environment.

Hmm. While I agree with your assessment I also wonder why you say
this. I guess Orion should work even if I am messy.


> If caching problem Simon found
> is the cause of your problems all you should do is this (for Chrome):
> 1. Open any Orion page
> 2. Options -> Under the Hood -> Clear Browsing Data -> choose to clean from
> "the beginning of time", tick browsing history, download history, empty the
> cache, delete cookies -> Clear browsing data

I think a new profile is more certain.  Anyway on a second machine I
did not need to clear my browser data nor create a new profile.

> 3. Go back to Orion page
> 4. F12
> 5. Go to Console tab
> 6. Type "localStorage.clear()"
> 7. you should get "undefined" as an result
> 8. Refresh the Orion page, twice for just for sure
>
> After this all missing plugins should be installed and their content should
> be up to date.

I believe that the only step that was essential for me was
localStorage.clear() followed by Shift-Control-R to reload.


> If you are running server on localhost default preferences can be found
> under this URL:
> http://localhost:8080/defaults.pref
>
> This is the latest version of it:
> {
>                 "/plugins":{
>                                 "authenticationPlugin.html": true,
>                                 "plugins/fileClientPlugin.html":true,
>                                 "plugins/jslintPlugin.html":true,
>                                 "git/plugins/gitPlugin.html":true,
>                                 "profile/userservicePlugin.html":true,
>                                 "plugins/user/userProfilePlugin.html":true,
>                                 "plugins/git/userProfilePlugin.html":true,
>                                 "plugins/webEditingPlugin.html":true,
>                                 "plugins/landingPageTasks.html":true,
>                                 "plugins/preferencesPlugin.html":true,
>                                 "plugins/taskPlugin.html": true
>                 }
> }
>
> If you did everything from my list and your defaults.pref content is as
> above than this is a different problem and we should investigate it.

Sorry I was not clear. Everything is working for me now. I was only
posting to the list to let anyone else who had the same symptoms know
that this problem was due to cache issues not code problems in 0.4m1.

Thanks,
jjb

>
> best regards,
> Malgorzata Janczarska
> Software Developer
> IBM SWG Lab. Cracow. Poland
>
> IBM Polska Sp. z o.o. oddział w Krakowie
> ul. Armii Krajowej 18,
> 30-150 Kraków
>
> NIP: 526-030-07-24
> Sąd Rejonowy dla m.st. Warszawy, XII Wydział Gospodarczy KRS
> KRS 0000012941, Kapitał Zakładowy: 33.000.000 PLN
>
> orion-dev-bounces@xxxxxxxxxxx wrote on 2011-12-17 18:50:25:
>
>> From:
>>
>> John J Barton <johnjbarton@xxxxxxxxxxxxxxx>
>>
>> To:
>>
>> Orion developer discussions <orion-dev@xxxxxxxxxxx>
>>
>> Date:
>>
>> 2011-12-17 18:52
>>
>> Subject:
>>
>> Re: [orion-dev] 0.4 M1 available
>>
>> Sent by:
>>
>> orion-dev-bounces@xxxxxxxxxxx
>>
>>
>
>> 2011/12/14 John J Barton <johnjbarton@xxxxxxxxxxxxxxx>
>> 2011/12/14 Malgorzata Tomczyk <Malgorzata.Janczarska@xxxxxxxxxx>:
>> >>
>> >> On Wed, Dec 14, 2011 at 3:19 AM, Szymon Brandys
>> >> <Szymon.Brandys@xxxxxxxxxx> wrote:
>> >> > Hi John,
>> >> >
>> >> > I think that clearing your browser cache may help here.
>> >>
>> >> Hi Szymon, which specific operation do you recommend?
>> >
>> > The error you have suggests that there is something wrong with a
>> > taskPlugin. Please go to plugins page and check if you have
> taskPlugin.html
>> > installed.
>
>> I'm now on another machine. I was unable to get anything to work. So I
>> reinstalled 0.4m1 and erased my serverworkspace. I exited my browser,
>> erased my browser profile. Then I started the server and the browser.
>>
>> Opening localhost:8080 and creating a new account works, but cloning a
>> repo fails:
>> Uncaught No Matching TaskService for
> location:/task/id/gCQLWn4mABEQAcLeeSiTng
>>
>> Just FYI, this problem was probably caused by a bug in preference
>> caching that Simon found.
>>
>> jjb _______________________________________________
>> orion-dev mailing list
>> orion-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/orion-dev
>
> _______________________________________________
> orion-dev mailing list
> orion-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/orion-dev