Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [nebula-dev] Contributions to Nebula GanttChart

Didn't want to blame you for the naming. By the time you implemented it, it was ok. :-)

Your suggestion sounds like a plan. I will modify it this way and contribute.

Thanks for the reply!

Am 27.07.2013 12:54 schrieb "Wim Jongman" <wim.jongman@xxxxxxxxx>:
Hi Wim,

I renamed your method because of the meaning of the method. My getCommands() is the getter for the commands while your getCommands() do some additional processing in flattening the commands. So in terms of API design it is the better choice. But of course I can change that. Any suggestions for another name to the real getter?


I totally agree that your naming is correct and that my naming is wrong. However, we cannot change the contract of an API method. 

I suggest you do the following: 

1. Copy your getCommands to getCommandList()
2. Change the getCommands method as a delegate to getFlattenedCommands
3. Mark the getCommands as deprecated and explain the deprecation in the javadoc

This way it is clear that the getCommands method is not correct, the user can see from the javadoc which method to call and we do not break the contract.

Cheers,

Wim



_______________________________________________
nebula-dev mailing list
nebula-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/nebula-dev


Back to the top