Skip to main content

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[mylyn-docs-dev] naming convention on "core" bundles

All,

We currently have a naming convention with a "core" suffix on all bundles and Maven artifacts that are not UI contributions to Eclipse.  For example:

org.eclipse.mylyn.wikitext.core
org.eclipse.mylyn.wikitext.ui
org.eclipse.mylyn.wikitext.textile.core
org.eclipse.mylyn.wikitext.textile.ui

This sticks out as like a sore thumb when looking at dependencies and other artifacts in a regular Maven build.

With the recent build changes, we've changed the major version number of WikiText from 2.x to 3.x.  This gives us a rare opportunity to make other breaking changes, such as renaming bundles.

I'd like to propose a naming change where we drop the "core" suffix, for example:

org.eclipse.mylyn.wikitext
org.eclipse.mylyn.wikitext.ui
org.eclipse.mylyn.wikitext.textile
org.eclipse.mylyn.wikitext.textile.ui

As part of this bundle renaming, we should also consider renaming java packages in those core bundles to drop the "core" suffix as well.

While the ".core" suffix naming naming convention could be seen as a cosmetic change, and therefore with little benefit or reason to change, I see it as being a potential source of confusion for consumers.  From a consumer perspective, what does "core" mean anyways, unless you're familiar with the convention?

What do you think?  

David
--


David Green | VP of Architecture Tasktop

email: david.green@xxxxxxxxxxx


Back to the top