[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [mylyn-dev] How come mylyn commons includes deps on org.eclipse.ui.editors?

Hi Eddie,

thanks for pointing that out. That's simply an oversight. The dependencies were removed in 3.7 but apparently the manifest wasn't updated accordingly. I have filed this bug to track this:

 378709: clean up unnecessary dependencies in o.e.m.commons.ui
 https://bugs.eclipse.org/bugs/show_bug.cgi?id=378709

Steffen


On Mon, May 7, 2012 at 7:08 PM, Eddie Galvez <eddie@xxxxxxxxxxxxxx> wrote:

Hi there,

 

I’m trying to transition my RCP application that was using mylyn notifications (pre 3.7.1) to the new bundles (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=376678) but I’m seeing a dependency from mylyn.commons.ui to org.eclipse.ui.editors. .editors means .ide (!) which isn’t the RCP-friendly side of Eclipse plug-ins…

 

Can the org.eclipse.ui.editors stuff be teased out or made optional?

 

Sadly unless somehow things work out even w the missing deps (not likely unless I really hacked things) I might have to roll back our product to the old mylyn bundles L

 

Thank you,

-          Eddie


_______________________________________________
mylyn-dev mailing list
mylyn-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/mylyn-dev




--
Steffen Pingel
Senior Software Developer, Eclipse Mylyn
Mylyn Tasks Lead
http://tasktop.com