[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] Mysterious maven-jar-plugin returns

Hi Nat - funny enough, I just upgraded to Kepler today and encountered the
same problem on a clean install. I'd checked out the Apache LDAP API and of
the 15 or so projects it created in Eclipse, just *one* of the projects had
that same error. I didn't actually upgrade but started clean - download
Kepler, install m2e and other plugins from the Marketplace, and did a
Maven-->Checkout Maven project from SCM. Downgrading to 2.3.2 did solve the
problem, which I only saw to do by finding your reported issue.

Sorry I don't have a helpful response but I wanted to add my +1 to the issue

-------------------------


From: m2e-users-bounces@xxxxxxxxxxx [mailto:m2e-users-bounces@xxxxxxxxxxx]
On Behalf Of Nathaniel Mishkin
Sent: Tuesday, August 06, 2013 6:30 PM
To: Maven Integration for Eclipse users mailing list
Subject: [m2e-users] Mysterious maven-jar-plugin returns

Last year (see http://dev.eclipse.org/mhonarc/lists/m2e-users/msg03633.html)
I reported an m2e issue I was having with the maven-jar-plugin, the short
story being the error:

org.codehaus.plexus.archiver.jar.Manifest.merge(org.codehaus.plexus.archiver
.jar.Manifest)

The suggested workaround (downgrading the maven-jar-plugin from 2.4 to
2.3.2) made the problem go away.  All that happened in the context of Indigo
and m2e 1.2.  Recently I've been trying to update by dev environment to
Kepler and m2e 1.4 and the problem returned, even though I'm still using the
workaround.  Removing the workaround didn't fix the problem either.

Any suggestions?

Thanks.

Nat