[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] After STS 3.3.0 (Kepler), getting two different very annoying exceptions when opening any file in two particular Maven projects

Hi Igor,

David has already raised 2 bugs with us
https://issuetracker.springsource.com/browse/STS-3481 and
https://issuetracker.springsource.com/browse/STS-3482. There is
nothing to suggest that this is coming from STS.  But, I will give
some suggestions on how to fix these.

David,
It may be that there is a missing plugin in your installation.  Don't
know how this could have happened, but it's possible. This file comes
from org.eclipse.jpt.common.utility_2.0.0.v201105110001.jar, but it is
missing in the 2.1.1 version of the jar.  The former is from Eclipse
4.2 (Juno) and the latter is from Kepler.  I am not sure why, but you
most likely have some Juno bits installed in your Kepler.  Did you
download from a zip or did you install from update sites?


On Thu, Jul 18, 2013 at 8:21 PM, Igor Fedorenko <igor@xxxxxxxxxxxxxx> wrote:
> Are you able to reproduce these problems with fresh/clean m2e install on
> one of Eclipse packages available from download.eclipse.org? If not,
> you probably want to report these to vmware.
>
> --
> Regards,
> Igor
>
>
>
> On 2013-07-18 7:26 PM, KARR, DAVID wrote:
>>
>> A few days ago I installed STS 3.3.0, which uses Kepler as the base.
>>
>> Most of the projects I browse are Ant projects, but two particular ones
>> that I spend a lot of time on are Maven projects.
>>
>> My initial testing of STS 3.3.0 is ok in general, except for a problem
>> with keyboard shortcuts that I see throughout, but I'm seeing particular
>> problems with my two Maven projects.  I don't see anything obviously related
>> to m2e in the stack trace for either problem (I get a different problem in
>> each of the two projects), but as these are Maven projects, I wondered
>> whether anyone has any ideas about this.
>>
>> In one project, which is a Java project, I get the following in an error
>> dialog when I open or switch the editor view to any file in that project:
>>
>> "java.lang.IllegalArgumentException: Path must include project and
>> resource name: /"
>>
>> Outside of the stack trace, which doesn't tell me much, it gives me no
>> additional information on what path this is referring to.
>>
>> I filed <https://bugs.eclipse.org/bugs/show_bug.cgi?id=412793> for this
>> problem.
>>
>> On the other project, which is a pure web project with no Java source, I
>> get the following error when I open or switch the editor view to any file in
>> that project:
>>
>> "java.lang.NoClassDefFoundError:
>> org/eclipse/jpt/common/utility/internal/AsynchronousCommandExecutor"
>>
>> The stacktrace is even more confusing, as it appears to be in the JPA
>> space.
>>
>> I filed <https://bugs.eclipse.org/bugs/show_bug.cgi?id=413258> for this
>> problem.
>>
>> Again, the only reason I'm asking this here is that these are Maven
>> projects, and I'm not seeing these symptoms with other non-Maven projects.
>>
>> Any useful ideas would be appreciated.
>> _______________________________________________
>> m2e-users mailing list
>> m2e-users@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/m2e-users
>>
> _______________________________________________
> m2e-users mailing list
> m2e-users@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/m2e-users